Drupal

Aus RaumZeitLabor Wiki
Wechseln zu: Navigation, Suche
     
Drupal

Release status: stable [box doku]

RaumZeitLabor - Logo - Schwarz.svg
Description
Owner(s)  Inte
Maintainer(s)  Inte

Wunschzettel

Optik

Funktionalität

Inhalt

  • Benutzer von Wordpress umziehen hat sich erledigt
  • Texte von Wordpress umziehen done
  • Kommentare von Wordpress umziehen
  • Bilder von Wordpress umziehen erledigt

Setup

Datenbanken

Um tiefere Eingriffe in diversen Konfigurationsdateien zu vermeiden sollte der Einfachheit halber der Benutzername und das Passwort der Drupal-, sowie der CiviCRM-Datenbank identisch sein oder nur eine Datenbank benutzt werden. Momentan befinden sich Drupal & CiviCRM-Daten in einer Datenbank.

Pfade

Modulverzeichnis
/sites/all/modules
Themeverzeichnis
/sites/all/themes

Theme

Anpassungen

Module

Core (optional)

Deaktiviert

Poll
Wurde nie benutzt.--Inte (Diskussion) 19:31, 15. Nov. 2012 (CET)

Nachinstalliert

Deaktiviert

Direct Debit Offline Gateway
Nur testweise benutzt, um Lastschriften von Spendenzusagen durchführen zu können.--Inte (Diskussion) 19:31, 15. Nov. 2012 (CET)
Tagadelic
Hatte eine Sicherheitslücke und brachte keinen wirklichen Mehrwert.--Inte (Diskussion) 19:31, 15. Nov. 2012 (CET)
Flattr
Funktionierte nach der Aktivierung von Default-SSL nicht mehr. Bugfix gibt's nur in der Version für Drupal 7.--Inte (Diskussion) 19:31, 15. Nov. 2012 (CET)

Anpassungen

Calendar

Für PHP 5.3 wird die aktuelle (>August 2010) Entwicklungversion empfohlen. Leider gibt es in dieser noch Probleme mit dem Import von CiviCRM-Events, weswegen noch mit der letzten stabilen Version (2.2) und PHP-5.3-Patch gearbeitet wird.

Tagadelic

Blendet Schlagwörter im Blog (Pfad: /blog), dessen einzelnen Seiten (Node type: blog) beim Erstellen eines Beitrags (Pfad: /node/add/blog) und allen Taxonomie-Seiten (Tags) in der rechten Seitenleiste ein.

Block
Left sidebar
Show block on specific pages
Show if the following PHP code returns TRUE (PHP-mode, experts only).
<?php
$match = FALSE;
$types = array('blog' => 1);
if (arg(0) == 'node' && is_numeric(arg(1))) {
  $nid = arg(1);
  $node = node_load(array('nid' => $nid));
  $type = $node->type;
  if (isset($types[$type])) {
    $match = TRUE;
  }
}

if (substr($_SERVER["REQUEST_URI"], 0, 10) == '/blog')
{ $match = TRUE;}

if (substr($_SERVER["REQUEST_URI"], 0) == '/node/add/blog')
{ $match = TRUE;}

if (arg(0) == 'taxonomy')
{ $match = TRUE;}

return $match;
?>

Drupal 7

Update Vorbereitungen

PHP Updates

A PDO database driver is required!
You need to enable the PDO_MYSQL database driver for PHP 5.2.4 or higher so that Drupal 7 can access the database.
See the system requirements page for more information.

Siehe auch